Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 17, 2025 - 12:00 UTC
Scheduled
In order to continuously improve the quality of our services the following maintenance is scheduled:
Start: 2025-06-17 12:00 UTC End: 2025-06-17 15:00 UTC Service impact: You may see occasional failed requests, while general service availability is assured. Service improvement: We will be upgrading the backend software of our S3 Object Storage cluster to a new minor release.
Thank you for your understanding.
Posted Jun 02, 2025 - 09:16 UTC
This scheduled maintenance affected: Cloud Services.