We have successfully completed the software upgrade.
Posted Mar 21, 2023 - 11:20 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2023 - 11:00 UTC
Scheduled
During this maintenance we will be upgrading the backend software of our S3 Object Storage cluster to a new patch release. We do not expect this to result in any service interruptions.